Home Forums Plugins Store Exporter Deluxe Support [Resolved] Same Fatal Error as Before

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #44776
    jkwalz
    Participant

    I did remove the old version of the plugin and install the new version and the store worked fine for a while. Then all of a sudden yesterday the same error started to pop up again so I renamed the plugin folder to .old. Once I did that the store worked fine again. Today I removed the plugin entirely and uploaded a fresh version of it from visser and then problem came back. I removed the folder from the plugin directory the error is still happening:

    Fatal error: Call to undefined function wp_get_current_user() in /home/jetbeads/public_html/wp/wp-includes/capabilities.php on line 448

    I even tried the version emailed to me and the error still occurs.

    #44778
    jkwalz
    Participant

    I think I fixed it. The file that you emailed me was missing the word “store” in the zipped directory name. I added it and uploaded it and the store seems to work now.

    #44779
    Michael Visser
    Keymaster

    Hi jkwalz, that sounds right. The 2.1.8 release would have been named woocommerce-store-exporter-deluxe while the ZIP I sent you would be woocommerce-exporter-deluxe. When you activated the broken 2.1.8 release it kicked up the same error but when you switched to the ZIP I sent it would work 🙂

    The 2.1.9 release includes a fix for the above scenario, if this pops up or anything you need help with open up a Support ticket so we can look at this together.

    https://www.visser.com.au/premium-support/

    #44805
    Marco
    Participant

    Hi, we had this Error permanently after upgrading to 2.1.8, so we downgraded to 2.1.7.

    After upgrading to 2.1.9, the error still happens occasionally. Its unclear under which circumstances, but it happens for some customers.

    Our 2.1.9 version is named woocommerce-store-exporter-deluxe.

    We disabled the plugin now.

    #44807
    jkwalz
    Participant

    It’s still happening with me too. It seems like the plugin is reverting to the corrupted previous version. Maybe because of the Visser Labs updater plugin?

    #44808
    kai
    Participant

    We did also get the same error – even after installing the 2.1.9 from the ZIP.
    Discovered just now that I am unable to export orders (everything else can be exported just fine) Don’t know if it is related…but thought I would mention it…

    #44865
    Michael Visser
    Keymaster

    Hi Jan, there was an empty Order issue introduced in the 2.1.9 urgent release which has been sorted in the 2.1.10 release that went out this afternoon. Can you please update to it and get in touch via Premium Support if this persists.

    The automatic Plugin update engine via the Dashboard > Updates screen is distributing the 2.1.10 Plugin update to users so it is safe to use. A series of very unfortunate incidents made the 2.1.8 update fail so spectacularly. If this issue persists for any users after updating to 2.1.9 or 2.1.10 please get in touch via Premium Support so we can look at this together.

    https://www.visser.com.au/premium-support/

    #44866
    jkwalz
    Participant

    Thanks Michael!

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Same Fatal Error as Before’ is closed to new replies.