Home Forums Plugins Store Exporter Deluxe Support [Resolved] PHP max_execution_time conflict?

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #44182
    Brian
    Participant

    I was able to set the max_execution_time via a php5.ini file to 300. This change is reflected in our phpinfo report. However, our exports keep crashing if they are bigger than 100 lines, and even the 100 line reports only spit out about 47 lines per export.

    We are getting this warning: “We could not detect or override the PHP configuration option max_execution_time, this may limit the size of large exports. See: Increasing PHP max_execution_time configuration option” despite the fact that the max_execution_time has been set.

    Could there be some way the plugin is not seeing this and running a time of only 30? Thanks for any guidance.

    #44187
    Michael Visser
    Keymaster

    Hi Brian, thanks for raising this.

    We raise that particular notice “We could not detect or override the PHP configuration option max_execution_time…” when the ini_get() PHP function returns false meaning it is hidden from our Plugin and from WordPress.

    You’d be seeing the alternate error “We could not override the PHP configuration option…” if we could detect the max_execution_time value but not increase it.

    Regarding why the export is failing at 30 seconds, this sounds like the timeout override you’ve added in php5.ini has not been applied to Apache or your web hosting software, can you try adjusting the max_execution_time option via php.ini, .htaccess or per your hosting provider’s suggestion.

    #44194
    Brian
    Participant

    Thanks for the great reply. I’ll check in with GoDaddy. The funny thing is that phpinfo recognizes the settings whether I use PHP.ini or PHP5.ini, but if I use a phpinfo plugin inside of WP — it doesn’t see the changes (still see 30 on the max_execution_time). So my settings are probably being disregarded.

    I wonder if the server would have to be rebooted? That would be great for a shared hosting box 😉

    #44204
    Michael Visser
    Keymaster

    You’re very welcome Brian, if this persists ping us on Premium Support so we can look at the details together; I bet hosting providers reboot shared servers more than customers realise 😉

    https://www.visser.com.au/premium-support/

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] PHP max_execution_time conflict?’ is closed to new replies.