Home Forums Plugins Add to Wishlist Support [Resolved] Wrong images on wish list url page

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #6442
    cyhwebby
    Participant

    I’ve noticed that when I navigate to my wish list, the wrong product images pop up next to the product names. The links and titles are all correct. Do you have any idea what this could be?

    #6443
    cyhwebby
    Participant

    I’ve been working on this awhile tonight and I think it’s due to this bit of code:

    $image_path = “index.php?image_id=”.$product_id.”

    On my installation of WP e-commerce, the image IDs are not the same as the product IDs. I am running WP 3.0 and WP E-commerce 3.7.6.7. I do have Gold Cart with multiple thumbnails enabled.

    I tried to dig into the code that is in the WP shopping cart as it loads the images properly, but it wasn’t a simple cut and paste operation, and that’s as far as I get in php code at the moment.

    What can I do to fix this? Thank you!

    #6444
    Michael Visser
    Keymaster

    Hi cyhwebby, I think you’re onto something! Each Product within wp_wpsc_product_list has an image reference column, this is the ID of the Product image ID. I’ll change this today and make an update available to resolve this.

    #6445
    j_blackburn
    Participant

    Did this issue get resolved? I have found that the image ID and product ID don’t always match. I have the same setup as cyhwebby WP 3.0 and WP E-commerce 3.7.6.7. I do have Gold Cart with multiple thumbnails enabled.

    Any timeline on a resolution?

    Thanks!

    #6446
    Michael Visser
    Keymaster

    Hi Joe, just sent you an e-mail, please download the 1.5.2 release of Add to Wishlist. 🙂

    #6447
    cyhwebby
    Participant

    Hey Michael, if I send you the login details to my site, could you have a look? I’ve installed the new 1.5.2 and it’s still not bringing up the right thumbnails. Thank you!

    #6448
    Michael Visser
    Keymaster

    Hi cyhwebby, please do, I’ll take a look 🙂

    #6449
    jessemarple
    Participant

    Michael,

    I’m having the same issues with images not showing up for the products. I receive a ‘no image’ image for each product on the wishlist though all of the products have images and thumbnails on the store. Could this have anything to do with function vl_wpscat_item_image?

    Help please!

    #6450
    ozoneboy
    Participant

    I’ve just encountered this problem with 1.5.2 as well. Michael can you please advise if there’s a fix coming and a rough eta???

    #6451
    Michael Visser
    Keymaster

    Please update to 1.5.4, a bug snuck in an earlier Plugin update. This is now resolved 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Wrong images on wish list url page’ is closed to new replies.