Home Forums Plugins Product Importer Deluxe Support [Resolved] No columns shown for mapping

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #6585
    mpjtone
    Participant

    I’m running WP 3.0.1 in multi-site mode and activated the plugins on a sub-site. I downloaded a fresh copy of Product Importer Deluxe 2.4.

    When I run the plugin (either category or product importer does the same thing), the first screen shows up fine and I browse for the CSV file as usual. When it uploads the file, though, there are no columns displayed for mapping, it only shows the header “First Row / CSV -> WP e-Commerce / Second Row”, then nothing and immediately after is the Import Options section.

    If I continue then I get the following error:

    Warning: Invalid argument supplied for foreach() in /nfs/c01/h08/mnt/6108/domains/wp3.jeannejohngren.com/html/wp-content/plugins/wp-e-commerce-product-importer-deluxe/wp-e-commerce-product-importer-deluxe.php on line 546

    Insuffient data was provided. Please ensure the required product import fields are available and have been matched.

    The minimum data requirements for importing into WP e-Commerce are:

    * SKU
    * Product Name
    * Category
    * Price

    I tried with the sample data file on your website, making no changes and get the same result.

    Please help!

    #6586
    Michael Visser
    Keymaster

    Hi mpjtone, can you please contact me directly as I’d like to confirm what directory the CSV file is being stored in, I suspect this is the issue you are experiencing in a multi-site environment.

    #6587
    mpjtone
    Participant

    Hi Michael, any news on this issue? The uploader still doesn’t work in WP3.0 with multi-site turned on. I’m stuck and have too many products to add by hand.

    #6588
    mpjtone
    Participant

    Hello – anything?

    Has anyone else been able to get Product Importer to work in a multi-site environment?

    #6589
    Michael Visser
    Keymaster

    Hi mpjtone, I’m wanting to look at this today. I’ve sent you an e-mail requesting login details, I imagine its a minor change to support multi-site environments but out of the box this support is not yet available; would love to add it!

    #6590
    Michael Visser
    Keymaster

    The issue experienced involved the fgetcsv() function not working as expected within that hosting environment, support for WordPress MU is working. The use of this function is a core requirement for the reading of CSV files, I’ll look into introducing an alternate CSV reading method to co-incide with the release of WP e-Commerce 3.8.

    #6591
    samudradaka
    Participant

    Hi, i’m getting the same problem. Running WordPress 3.0.1 in single site mode with Product Importer Deluxe 2.6.1.

    I have it installed WordPress in a sub-directory while i’m testing and adding content – and the current (non-wordpress) live site at the root level funnily enough uses fgetcsv to read csv files and works fine. I tried using the sample-deluxe.csv file and get same error.

    So could it be something else – I though maybe a folder/file permissions issue – but with all the folders set to chmod 0777 from /uploads downwards and also adding chmod(WPSC_FILE_DIR.$file[‘name’], 0777); before the @fopen comand it still throws the same error.

    I also tried adding ini_set(‘auto_detect_line_endings’, true); and this didn’t help.

    Any clues? I’m trying to get this site up quick which is why I bought this plugin so a quick response would be much appreciated. Am happy to try suggestions if you want to email me.

    Thanks

    Vali

    #6592
    samudradaka
    Participant

    P.S Here’s some other info that may help: I can see via ftp that the csv get’s uploaded ok but then.i tried echoing the contents of $handle, $content and $fields around line100 and they all come up blank. so for some reason it’s not able to read the contents of the csv. i also tried changing the way the csv file is addressed and this didn’t help. with error reporting switched on it doesn’t throw any fatal errors.

    Vali

    #8467
    klaus
    Participant

    Hi Michael,

    I just got the same error “Insuffient data was provided. Please ensure the required product import fields are available and have been matched” whilst running a test csv file which does have those fields all included, and they did match up.

    I am running WP e-commerce Version 3.8.6.1 and your fine Product Importer Deluxe version 2.8.8.

    As we host the site ourselves, I can make any required hosting changes, if needed.

    Thank you, Klaus

    #8470
    klaus
    Participant

    Hi Michael,

    It sure would be great to have a response to my question, as the client is pushing me and I am unable to upload the CSV file and move ahead.

    Thank you, Klaus

    #8570
    Michael Visser
    Keymaster

    Hi Klaus, apologies for the delay in responding, I’ve just released a major overhaul of Product Importer Deluxe to play nicer with WP e-Commerce (both 3.7 and 3.8). Can you please install the latest Plugin update and confirm if you are still experiencing this issue, thanks Klaus. 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] No columns shown for mapping’ is closed to new replies.