Home Forums Plugins Product Importer Deluxe Support Imports not working

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6564
    Huff360
    Participant

    I have a new site setup with the following specs:

    Dedicated Win server 2008 R2 Standard
    IIS 7.5
    PHP 5.2.14
    MySQL 5.1
    Wordpress 3.0.1
    (these were installed using the Windows Web App Gallery installer)
    Gold Cart 2.4
    Cat. Importer 1.4
    Prod. Importer Dlx 2.2
    e-commerce 3.7.6.7
    other misc plugins – shadowbox js, wp-mail-smtp

    (I think thats everything…. )

    I am trying to import from the sample .csv file hosted here at visser labs.

    When I import categories, everything seems to work fine. No error messages and it says 5 imports successful. Problem is, there are no categories added. I get the same result when I try to import products with manually configured categories. I verified that there are no products being written to the table using phpmyadmin. If I add a test product by hand, I can see it in phpmyadmin, but none of the imported products show up.

    I did some digging around, and found that there were some entries being written to C:windowstempphp-errors.log

    This is what is there after one try with the sample .csv –

    4 occurrences of :
    [27-Aug-2010 21:07:23] WordPress database error Table ‘hp.wp_wpsc_checkout_forms’ doesn’t exist for query SELECT * FROM wp_wpsc_checkout_forms WHERE active = ‘1’; made by require_once, require_once, require_once, include_once, require_once, require_once, wpsc_purchaselogs->wpsc_purchaselogs, wpsc_purchaselogs->getall_formdata

    and 1 occurrence of this for each category:
    [27-Aug-2010 21:07:36] WordPress database error Field ‘description’ doesn’t have a default value for query INSERT INTO wp_wpsc_product_categories (group_id,name,nice-name) VALUES (‘1′,’Accessories’,’accessories’) made by do_action, call_user_func_array, vl_wpscci_html_page

    Any ideas? This is a dedicated server just for this website, and I have full control of the server so any changes can be made.

    Thanks

    #6565
    Michael Visser
    Keymaster

    Hi Huff360, what I suspect is happening has been raised prior and fixed by Marc. This is an issue with hosting servers running IIS.

    the way the tables are interpreted are different between linux and windows. From what I understand MySQL on windows interprets a missing default value as an error but in Linux it interprets it as a warning. I removed lines 86 & 87 from my.ini thereby disabling strict mode and voila! Everything works.

    Please let me know if this fixes it as I’ll add this to the documentation for this Plugin.

    #6566
    Huff360
    Participant

    That was the trick. Many thanks.

    For others reference –

    C:Program FilesMySQLMySQL Server 5.1my.ini

    Line 87 was…

    sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

    changed to

    # sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

    restarted the server and imports worked fine.

    Many thanks for the quick response.

    #6567
    Michael Visser
    Keymaster

    Nice! Thanks for the details I’ll get that up for others to see 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Support’ is closed to new topics and replies.