Home Forums Plugins Store Exporter Deluxe [Resolved] Excel export Cell format / style

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #43480
    Juan Carlos
    Participant

    Hi,
    When exporting to excel (.xls version), all my cells get formatted as “General” by default. Is it possible to make the export format the cells as “Text” (required by my provider)

    If it is not supported, can you at least give me some clue about what file / line of code should I have to hack in order to try to change that by myself?

    Thanks a lot!

    Regards

    #43484
    Michael Visser
    Keymaster

    Hi Juan, thanks for asking. Sure can!

    1. Open up WooCommerce > Store Export > Settings screen
    2. Jump to the CSV Settings section
    3. Beside the Field escape formatting change it to “Escape all fields” which will treat all fields as strings (Text in your case)
    4. Click Save Changes

    🙂

    (I’ll move that option from the CSV Settings section to General for the 2.1.4 Plugin update)

    #43488
    Juan Carlos
    Participant

    Thanks for the quick support,
    But it is not working. I see that I already have the “Escape all fields” setting enabled. So I’m getting the same result with this setting.

    All mi excel fields are detected by excel as “General” formatting.

    #43609
    Juan Carlos
    Participant

    After trying different ways, even exporting as csv, I’ve found that I would need something like the option to “escape NO field”, because my provider expects to receive a CSV like field1;field2;field3 and the plugin is generating “field1″;”field2″;”field3”.

    Any way I can make it export without the escape characters?

    Thanks a lot

    #43934
    Michael Visser
    Keymaster

    Hi Juan, this topic is an oldie but a good one. I’ve added support for no cell escaping in the 2.1.5 Plugin update going out today 🙂

    Just open up the WooCommerce > Store Export > Settings screen and change the Field escape formatting option to ‘none’ 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Excel export Cell format / style’ is closed to new replies.