Home Forums Plugins Store Exporter Deluxe Support [Resolved] Support for attributes with numbers in slug

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33297
    arboralto
    Participant

    I opened a support request for this (2704) but haven’t heard back, so I’m trying here.

    I have up to 10 attributes for a product. When trying to export an order with all 10 attributes selected, there is a bug where the first attribute matches the last attribute. I think the issue is with how I’ve named these. The slugs are blend-1, blend-2, blend-3, etc. So I’ve added ‘pa_blend-1, pa_blend-2, pa_blend-3’ into the custom order fields, Order Item Meta box. This works fine, unless an order includes both a ‘pa_blend-1’ and ‘pa_blend-10’ attribute. In this case pa_blend-1 always returns the value of pa_blend-10. I’m guessing that its looping through the attribute names and returning the first result. Is this using SQL LIKE somewhere that would return ‘pa_blend-10’ when searching for ‘pa_blend-1’?

    #33419
    Michael Visser
    Keymaster

    Hi arboralto, can you send me an e-mail at michael@visser.com.au, this one’s been very difficult to reproduce but would be happy to assist you in resolving this. I’ve responded to your Premium Support topic

Viewing 2 posts - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Support for attributes with numbers in slug’ is closed to new replies.