The Visser Labs team is growing with a newborn baby; a healthy girl named Eva! Use coupon: babybaby-20 for 20% off all Plugins.
Support is limited until Michael gets some sleep! :)

Plugin compatibility after unsuccessful WP e-Commerce 3.7 to 3.8 Plugin upgrade

A quick note affecting my WP e-Commerce Plugins where an existing WP e-Commerce 3.7 store has been upgraded to the latest WP e-Commerce 3.8 before – for whatever reason – rolling back to their existing WP e-Commerce 3.7 files.

WP e-Commerce has a WordPress option within the wp_options table of the database called ‘wpsc_version’ which once upgraded to 3.8 changes from a value of ‘3.7’ to ‘3.8.x’, if you have rolled-back from WP e-Commerce 3.8 to an older 3.7 release you will need to manually adjust this value back to ‘3.7’ as it is reported WP e-Commerce 3.7 does not do this by itself, this can be done with phpMyAdmin or other database management tools provided by your hosting provider.

Leaving this WordPress option unchanged confuses my Plugins which depends on this for identifying the correct WP e-Commerce files as well as its own version-based files to load during activation and daily use. If you’re noticing weird error messages after rolling back it’s quite likely the above scenario is at fault.

If you get stuck feel free to shoot me a message as it’s an easy fix.

Leave a Comment

Before you comment - Do you have a support request? If so, this is not the right place to post it. Please submit support requests for Premium Plugins on the Support page and in the community Support Forums for free Plugins.

Your email address will not be published.